Linux, FreeBSD, Juniper, Cisco / Network security articles and troubleshooting guides
https://forum.ivorde.com/

PERL can't set the locale; make sure $LC_* and $LANG are correct
https://forum.ivorde.com/perl-can-t-set-the-locale-make-sure-lc-and-lang-are-correct-t88.html
Page 1 of 1

Author:  designeru [ Thu May 20, 2010 12:40 pm ]
Post subject:  PERL can't set the locale; make sure $LC_* and $LANG are correct

If you wish to fix the following errors (on debian google for other distributions)
Code:
can't set the locale; make sure $LC_* and $LANG are correct

or
Code:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

Do this:
Code:
apt-get update
apt-get install belocs-locales-bin belocs-locales-data

then add to /etc/locale.gen the locales that you're ussing. I have the following:
Code:
cat /etc/locale.gen
en_US.UTF-8 UTF-8

And finaly do this:
Code:
# locale-gen
Generating locales...
en_US.UTF-8... done
Generation complete.


The error should be fixed now. No reboot required.

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/