Linux, FreeBSD, Juniper, Cisco / Network security articles and troubleshooting guides
https://forum.ivorde.com/

php 5.4 Cannot load module 'memcached' because required module 'igbinary' is not loaded in Unknown
https://forum.ivorde.com/php-5-4-cannot-load-module-memcached-because-required-module-igbinary-is-not-loaded-in-unknown-t15911.html
Page 1 of 1

Author:  mandrei99 [ Wed Dec 11, 2013 11:10 am ]
Post subject:  php 5.4 Cannot load module 'memcached' because required module 'igbinary' is not loaded in Unknown

Code:
[11-Dec-2013 14:28:49] NOTICE: PHP message: PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20100525/igbinary.so' - /usr/local/lib/php/20100525/igbinary.so: Undefined symbol "ps_globals" in Unknown on line 0
[11-Dec-2013 14:28:49] NOTICE: PHP message: PHP Warning:  Cannot load module 'memcached' because required module 'igbinary' is not loaded in Unknown on line 0


It's a known thing that php extensions load order is important. Thus, the session extension has to be one of the first to be loaded (as per https://bugs.php.net/bug.php?id=61348&edit=1).

PHP extensions load order is:
session
igbinary
memcached

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/