FreeBSD uses
ndp (Neighbor Discovery Protocol) utility to liste IPv6 information.
Quote from "man ndp":
Quote:
NDP(8) FreeBSD System Manager's Manual NDP(8)
NAME
ndp -- control/diagnose IPv6 neighbor discovery protocol
SYNOPSIS
ndp [-nt] hostname
ndp [-nt] -a | -c | -p
ndp [-nt] -r
ndp [-nt] -H | -P | -R
ndp [-nt] -A wait
ndp [-nt] -d hostname
ndp [-nt] -f filename
ndp [-nt] -i interface [expressions ...]
ndp [-nt] -I [interface | delete]
ndp [-nt] -s nodename etheraddr [temp] [proxy]
DESCRIPTION
The ndp utility manipulates the address mapping table used by the Neigh-
bor Discovery Protocol (NDP).
-a Dump the currently existing NDP entries. The following informa-
tion will be printed:
Neighbor IPv6 address of the neighbor.
Linklayer Address
Linklayer address of the neighbor. It could be
``(incomplete)'' when the address is not available.
Netif Network interface associated with the neighbor cache
entry.
Expire The time until expiry of the entry. The entry could
become ``permanent'', in which case it will never
expire.
S State of the neighbor cache entry, as a single letter:
N Nostate
W Waitdelete
I Incomplete
R Reachable
S Stale
D Delay
P Probe
? Unknown state (should never happen).
Flags Flags on the neighbor cache entry, in a single letter.
They are: Router, proxy neighbor advertisement (``p'').
The field could be followed by a decimal number, which
means the number of NS probes the node has sent during
the current state.
Code:
# ndp -a
Neighbor Linklayer Address Netif Expire S Flags
fe80::20c:29ff:fe2a:32ba%em1 00:0c:29:2a:32:ba vmx1 permanent R
fe80::2e21:72ff:fec6:c188%em0 2c:21:72:c6:c1:88 vmx0 23h40m13s S R
fe80::20c:31ff:fe2a:32b0%em0 00:0c:29:2a:32:b0 vmx0 permanent R
FreeBSD uses [b]ndp[/b] (Neighbor Discovery Protocol) utility to liste IPv6 information.
Quote from "man ndp":
[quote]NDP(8) FreeBSD System Manager's Manual NDP(8)
NAME
ndp -- control/diagnose IPv6 neighbor discovery protocol
SYNOPSIS
ndp [-nt] hostname
ndp [-nt] -a | -c | -p
ndp [-nt] -r
ndp [-nt] -H | -P | -R
ndp [-nt] -A wait
ndp [-nt] -d hostname
ndp [-nt] -f filename
ndp [-nt] -i interface [expressions ...]
ndp [-nt] -I [interface | delete]
ndp [-nt] -s nodename etheraddr [temp] [proxy]
DESCRIPTION
The ndp utility manipulates the address mapping table used by the Neigh-
bor Discovery Protocol (NDP).
-a Dump the currently existing NDP entries. The following informa-
tion will be printed:
Neighbor IPv6 address of the neighbor.
Linklayer Address
Linklayer address of the neighbor. It could be
``(incomplete)'' when the address is not available.
Netif Network interface associated with the neighbor cache
entry.
Expire The time until expiry of the entry. The entry could
become ``permanent'', in which case it will never
expire.
S State of the neighbor cache entry, as a single letter:
N Nostate
W Waitdelete
I Incomplete
R Reachable
S Stale
D Delay
P Probe
? Unknown state (should never happen).
Flags Flags on the neighbor cache entry, in a single letter.
They are: Router, proxy neighbor advertisement (``p'').
The field could be followed by a decimal number, which
means the number of NS probes the node has sent during
the current state.[/quote]
[code]# ndp -a
Neighbor Linklayer Address Netif Expire S Flags
fe80::20c:29ff:fe2a:32ba%em1 00:0c:29:2a:32:ba vmx1 permanent R
fe80::2e21:72ff:fec6:c188%em0 2c:21:72:c6:c1:88 vmx0 23h40m13s S R
fe80::20c:31ff:fe2a:32b0%em0 00:0c:29:2a:32:b0 vmx0 permanent R [/code]