Linux, FreeBSD, Juniper, Cisco / Network security articles and troubleshooting guides

FAQ
It is currently Mon Nov 11, 2019 11:50 pm


Username:
Subject:
Message body:
Enter your message here, it may contain no more than 60000 characters. 

Smilies
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:
Font size:
 
Font colour
Options:
BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON
Disable BBCode
Disable smilies
Do not automatically parse URLs
Confirmation code
Confirmation code:
In an effort to prevent automatic submissions, we require that you enter both of the words displayed into the text field underneath.
     

Topic review - FreeBSD - Can't locate Mail/Header.pm in @INC (@INC contains:
Author Message
Post subject: FreeBSD - Can't locate Mail/Header.pm in @INC (@INC contains:  |  Post Posted: Thu Jul 29, 2010 3:00 am
While running the cyrus2courier perl script, I ran into the following error:
Quote:
# /usr/bin/perl /tmp/maildir2cyrus-uid-internaldate
Can't locate Mail/Header.pm in @INC (@INC contains: /usr/local/lib/perl5/5.8.8/BSDPAN /usr/local/lib/perl5/site_perl/5.8.8/mach /usr/local/lib/perl5/site_perl/5.8.8 /usr/local/lib/perl5/site_perl /usr/local/lib/perl5/5.8.8/mach /usr/local/lib/perl5/5.8.8 .) at /tmp/maildir2cyrus-uid-internaldate line 60.
BEGIN failed--compilation aborted at /tmp/maildir2cyrus-uid-internaldate line 60.



For this, the perl MailTools module is needed.

To install Mail-Tools perl module on FreeBSD:
Code:
# make install -C /usr/ports/mail/p5-Mail-Tools
===>  License check disabled, port has not defined LICENSE
=> MailTools-2.06.tar.gz doesn't seem to exist in /usr/ports/distfiles/.
=> Attempting to fetch from ftp://ftp.funet.fi/pub/languages/perl/CPAN/modules/by-module/Mail/.
MailTools-2.06.tar.gz                         100% of   52 kB   68 kBps
===>  Extracting for p5-Mail-Tools-2.06
=> MD5 Checksum OK for MailTools-2.06.tar.gz.
=> SHA256 Checksum OK for MailTools-2.06.tar.gz.
===>   p5-Mail-Tools-2.06 depends on file: /usr/local/bin/perl5.8.8 - found
===>  Patching for p5-Mail-Tools-2.06
===>   p5-Mail-Tools-2.06 depends on file: /usr/local/bin/perl5.8.8 - found
===>   p5-Mail-Tools-2.06 depends on file: /usr/local/bin/perl5.8.8 - found
===>  Configuring for p5-Mail-Tools-2.06
WARNING: LICENSE is not a known parameter.
Checking if your kit is complete...
Looks good
Warning: prerequisite Test::Pod 1 not found.
'LICENSE' is not a known MakeMaker parameter name.
Writing Makefile for Mail
===>  Building for p5-Mail-Tools-2.06
cp lib/Mail/Address.pm blib/lib/Mail/Address.pm


The rest is obvious...
Jump to:  
cronNews News Site map Site map SitemapIndex SitemapIndex RSS Feed RSS Feed Channel list Channel list


Delete all board cookies | The team | All times are UTC - 5 hours [ DST ]



phpBB SEO